Network Instability - DDoS Mitigation Provider
Resolved
Oct 10 at 08:42am CDT
Resolved: Ongoing botnet attacks have degraded the performance of worldwide DDoS mitigation providers and ISPs. This has resulted in some network instability with brief fluctuations and disconnections due to large and sophisticated attacks. Many providers are currently having issues due to ongoing widespread attacks this year.
These attacks have been causing connectivity and downtime for Steam, AWS, Riot Games, League of Legends, PSN, Valorant, Hulu, EA, Marvel Rivals, Call of Duty, Palworld, and more. ISPs and critical routing infrastructure have been targeted, which cause network disruptions worldwide. Our DDoS protection provider is working toward a solution.
Affected services
Created
Oct 05 at 06:52am CDT
Ongoing botnet attacks have degraded the performance of worldwide DDoS mitigation providers and ISPs. This has resulted in some network instability with brief fluctuations and disconnections due to large and sophisticated attacks. Many providers are currently having issues due to ongoing widespread attacks this year.
These attacks have been causing connectivity and downtime for Steam, AWS, Riot Games, League of Legends, PSN, Valorant, Hulu, EA, Marvel Rivals, Call of Duty, Palworld, and more. ISPs and critical routing infrastructure have been targeted, which cause network disruptions worldwide. Our DDoS protection provider is working toward a solution.
Affected services